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tuait une avancée importante avec no-

tamment I'implémentation du compo-
sant Chart2 améliorant la création, le para-
métrage et la mise en forme des diagram-
mes sous Calc. Depuis, la version 2.4 et la
version 3.0, en apportant de nouvelles fonc-
tionnalités ou en en améliorant celles exis-
tantes, permettent aux utilisateurs d’Open-
Office.org de bénéficier d'un outil complet
et efficace pour tracer des courbes ou des-
siner des diagrammes, et d’illustrer ainsi
leurs documents.

Une des nouveautés de la version 3.0
est la possibilité d'afficher I'équation d’une
régression de facgon plus claire ou d’afficher
sur les « courbes XY » des marges d’erreurs
prédéfinies dans des cellules.

Cet article, en revenant d’abord sur I'uti-
lisation de base du tableur Calc, expose ces
nouvelles fonctionnalités, au travers d’exem-
ples simples.

I a version 2.3 d’OpenOffice.org consti-

Saisie et traitement
des données

Lutilisation des fonctions de saisie de base
de Calc ne présente pas de difficultés. Calc
propose toutefois quelques outils particu-
liers simplifiant cette tache.
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Figure 1. Une utilisation de la fonction
Somme

Repérage des cellules

et utilisation des noms

Un tableur est formé de lignes (identifiées
par des chiffres) et de colonnes (identifiées
par des lettres) dont les croisements for-
ment des cellules. Lors de la saisie de for-
mules ou de fonctions, il est fréquent de
faire appel au contenu d’autres cellules de
cette fagcon : « Al », « D9 »...

Lors de la copie de la formule, par exem-
ple «=C5+B1 », de la cellule «Al» vers la
cellule « A3 », la formule se transforme en
« =C7+B2 » c’est-a-dire que I'indice de ligne
est automatiquement incrémenté de 2.

C'est bien slr également le cas lors
d’une copie vers une autre colonne ou une
combinaison des deux changements (lighe
et colonne). Cela tient au fait que lorsque
vous tapez « =C5+B1 », vous choisissez im-
plicitement une méthode de copie relative
a I'adresse cellule.

C'est parfois le but recherché mais
il peut étre intéressant dans certains cas de
choisir une méthode de copie absolue, no-
tamment pour les formules fixes. Il faut alors
placer un symbole $ devant la référence a
figer. Par exemple, pour maintenir constant
indice de colonne dans la formule
« =C5+B1 », il suffit d’inscrire « =$C5+$B1 ».
Le fonctionnement est analogue pour les li-
gnes. Il est bien entendu possible de figer les
deux indices (lignes et colonnes) en méme
temps, de cette fagon : « =$C$5+$B$1 ».

Toutefois, I'utilisation des symboles $
rend peu lisibles les longues formules, com-
me vous pouvez le constater sur la formule
précédente, pourtant trés courte. Calc four-
nit donc un autre outil : la définition de noms
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Figure 2. Exemple de liste de tri

pour des cellules ou des plages de
cellules.

Sélectionnez la cellule ou la pla-
ge de cellules @ nommer, puis allez
dans le menu Insertion -> Noms ->
Définir. Aprés avoir inscrit le nom (il
ne doit pas contenir d’espaces), cli-
quez sur Ajouter puis OK. La liste
des noms apparait dans le champ
Zone de nom de la barre d’outil de
saisie de formules et est également
présente dans le navigateur.

Par la suite, lorsque vous saisirez
le nom dans une formule, aprés avoir
entré les premiers caractéres, vous
verrez le nom entier s’afficher sous la
forme d’une infobulle, dont vous vali-
derez la proposition par la touche
[Entrée]. Si plusieurs noms devaient
commencer par les mémes caracte-
res, la touche de tabulation permet
d’atteindre le nom recherché.

Vous avez enfin la possibilité de
définir des noms a partir de cellules
contenant du texte. Par exemple,
pour le tableau de la Figure 1, pour
effectuer la somme des éléments de
la colonne 1, inscrivez la formule
«=SOMME(‘Colonne 1’)». Ce nom
doit commencer par une lettre et s’il
comporte une apostrophe, elle devra
étre précédée d’un antislash « \ ».

Cette fonction est activée par
défaut dans Calc ; si besoin, désac-
tivez-la grace au menu Outils -> Op-
tions -> OpenOffice.org Calc ->
Calcul en décochant la case Re-
chercher automatiquement les éti-
quettes de colonnes et lignes. Cela
s’aveére utile, en particulier pour une
feuille de calcul de grande taille,
afin d’éviter toute confusion dans
les formules entre les différentes
étiquettes.

Utilisation des fonctions

Calc dispose d’un assistant pour les
fonctions, accessible dans la barre
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d’outils de saisie de formules (pre-
mier bouton a gauche aprés le
champ Zone de nom). Lune des
fonctions les plus souvent utilisées
étant la fonction « Somme », un bou-
ton lui a été dédié ; il est situé a gau-
che du signe égal dans la barre
d’outils de saisie de formules.

Son utilisation est particuliére-
ment facile puisqu’il suffit de se pla-
cer dans une cellule vide, suivant
une ligne ou une colonne de don-
nées, de cliquer sur le bouton Som-
me, puis de taper sur la touche [En-
trée], sachant que Calc détecte
automatiquement les données de
type textuelles éventuellement pré-
sentes dans le tableau et n’en tient
donc pas compte dans le calcul de
la somme.

L'assistant contient de nombreu-
ses fonctions, classées en onze ca-
tégories parmi lesquelles les fonc-
tions statistiques, mathématiques,
date/heure, finance, informations
(sur la nature du contenu de la cel-
lule), texte. Il est parfois utile d’'im-
briquer plusieurs fonctions, ce qui
se fait aisément grace a l'onglet
Structure de I'assistant.

Aides a la rédaction

Calc dispose des mémes fonction-
nalités que Writer en ce qui concer-
ne 'aide a la rédaction : notes, re-
péres et mode Modifications. Mais
il propose également des outils
spécifiques, décrits dans ce para-
graphe.

Afficher ou masquer des lignes
Lors de la rédaction de longs
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le menu Format -> Lignes/Colon-
nes -> Afficher.

Listes de tri

Les listes de tri permettent de faire
« glisser» les informations d’une
cellule vers les cellules adjacentes
de la méme ligne ou de la méme co-
lonne (voir Figure 2).

Par exemple, saisissez le texte
« Lundi » dans une cellule vide. Sé-
lectionnez la cellule puis cliquez sur
le coin inférieur droit du bord de cel-
le-ci. Ensuite, faites glisser la cellule
sur plusieurs cellules vers la droite
ou vers le bas. Lorsque vous rela-
chez le bouton, vous constatez que
les cellules mises en évidence affi-
chent les noms des jours de la se-
maine.

Eventuellement, paramétrez vos
propres listes de tri dans le menu
Outils -> Options -> OpenOffice.org
Calc -> Listes de tri, car seules les
listes des jours de la semaine et des
mois de I'année sont prédéfinies.

Utilisation de I'assistant
pour la création
de diagrammes

La nouvelle version de l'assistant
de création de diagrammes offre
une plus grande souplesse et de
nombreuses possibilités supplé-
mentaires dont celle de générer
beaucoup plus aisément des gra-
phiques contenant plusieurs cour-
bes, d’abscisses et d’ordonnées
différentes. Laffichage des équa-
tions de régression a également été
implémenté.

documents, masquer des li-
gnes ou des colonnes facili-
te parfois la tache : placez-
vous sur la ligne ou sur la
colonne a masquer, puis cli-

quez sur Masquer dans le s

menu Format -> Lignes/Co-
lonnes : la ligne ou la colon-
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ment masqué et allez dans

Figure 3. Superposition de deux courbes
d’échelles différentes sur un méme
graphique
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sont cochées automatiquement
si la sélection du tableau est
simple.

C'est le paramétrage de la
troisieme étape (voir Figure 4),
nommée Séries de données, qui
varie selon la nature du graphi-
que a générer. La premiére par-
tie de la fenétre, le cadre « Sé-
ries de données », correspond a
la liste de I'ensemble des cour-
bes a faire apparaitre sur le gra-
phique : il s’agit des colonnes
des ordonnées. Les boutons
Ajouter et Supprimer ainsi que

Figure 4. Assistant pour la création de diagramme

Au travers d’exemples simples, possible d’insérer les données en
nous passerons en revue l'utilisation  lignes.

de ces nouvelles fonctionnalités. Aprés sélection de ce tableau,

en-téte comprise, l'assistant de
Superposition de courbes création de graphiques est lancé par
dans un méme graphique le menu Insertion -> Diagramme...

Pour comparer différents phénomé-  ou par le bouton Diagramme de la
nes, afficher plusieurs courbes dif- barre d’outil « Normal». La fenétre
férentes dans un seul graphique est  de l'assistant qui s’ouvre propose
parfois utile. Mais ces différentes  une création en quatre étapes.

courbes ne possédent pas forcé- La premiére étape consiste en la
ment les méme échelles en abscis-  sélection du type de diagramme vou-
se et en ordonnée. lu, ici « XY (dispersion) », option « Li-

gnes seules ». Pour la mise en forme,
Superposition simple nous avons également sélectionné

La Figure 3 représente la version  I'option Lignes lisses. Les options dis-
la plus simple de superposition de  ponibles dépendent bien entendu du
courbes : les deux courbes possé-  type de diagramme sélectionné.

dent la méme échelle en abscisse La seconde étape ne nécessite
et en ordonnée. Pour générer ce  a prioriaucune modification puisque
graphique, nous avons pris pour la sélection de la plage de données
base un tableau de données a été faite avant I'ouverture de I'as-
contenant une colonne pour I'abs-  sistant. Les options telles que « Pre-
cisse et une autre pour chaque miére ligne comme étiquette » ou
courbe. Il est bien sOr tout a fait «Séries de données en colonnes »

les fléches situés aux bas de ce
cadre permettent de modifier le
nombre de courbes a afficher.

La seconde partie de la fené-
tre (Plage pour...) permet, quant
a elle, de définir les plages de don-
nées, que ce soit pour I'abscisse ou
I'ordonnée ainsi que I'adresse du
nom de la plage et ce, pour chacune
des courbes, c’est-a-dire pour cha-
cune des « séries de données » insé-
rées dans le premier cadre.

Ici, pour chacune des deux cour-
bes, le champ « Valeurs-X » sera le
méme : la colonne abscisse. Pour
sélectionner directement les colon-
nes de données, cliquez le bouton
situé a la droite du champ de saisie
puis sélectionnez la colonne avec la
souris.

Le champ Etiquettes de données
sert a attribuer a certains points de
la courbe un nom particulier, diffé-
rent de la valeur elle-méme du
point.

Enfin, la derniére étape, Eléments
du diagramme, permet d’insérer des
éléments annexes : titre et sous-titre

du graphique, titres des axes, po-
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sition de la légende et affichage
des grilles. Plus d’options pour la
configuration de ces différents
éléments sont accessibles une
fois le graphique gxénéré.

Aprés avoir cliqué sur le bou-
ton Terminer de l'assistant de
création de diagramme, vous
constatez ne pas étre dans la
fenétre courante de Calc : les
barres d’outils et les menus sont
différents. Pour y retourner, il
suffit de cliquer n’importe ol en

dehors du diagramme et pour
passer de la fenétre courante
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a la fenétre d’édition du diagramme
il faut double-cliquer sur celui-ci.
Examinons rapidement cette fené-
tre particuliére de Calc.

Le menu Insertion permet de
modifier le contenu des titres et des
axes, de paramétrer la présence
des grilles ainsi que la position de la
lIégende, le menu Format permet-
tant la mise en forme de chacun de
ces éléments. Ce menu donne éga-
lement accés aux paramétres pour
I'étiquetage des données, dont la
version 2.4 offre de plus amples
possibilités dans le placement et le
choix du format. La derniére entrée
dont dispose ce menu, Statistiques,
concerne les régressions et I'inser-
tion sur le graphique de données
statistiques comme la moyenne, la
variance ou I'écart-type. Nous y re-
viendrons dans la suite de I'article.

Outre la mise en forme des titres,
axes, grilles et de la Iégende, le menu
Format, offre la possibilité de changer
le type de diagramme choisi lors de la
création ou la plage de données du
diagramme. Il permet enfin de modi-
fier le «plancher du diagramme »
lorsqu’il s’agit d'un diagramme 3D.

La barre d’outils « Formatage »
contient assez peu d’éléments mais
notez la présence du bouton échelle
de texte qui, s’il est activé, provoque
une modification dynamique de
I’échelle des éléments de texte du
diagramme (titres, nom des axes,
etc.) lorsque la taille du diagramme
est modifiée.

Dans le cas de I'utilisation de plu-
sieurs courbes, comme ici, person-
nalisez éventuellement la couleur
par défaut de chaque courbe grace
au menu Outils -> Options -> Dia-
grammes -> Couleurs par défaut.

Enfin, lorsque les données sont
modifiées aprés la création du dia-
gramme, sa mise a jour est automa-
tique. Autrement dit, toute modifica-
tion dans le tableau de données est
répercutée dans le diagramme.
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Axe Y secondaire =
Lorsque deux séries de
données possédent une s
abscisse similaire mais
une échelle différente s
pour les ordonnées, il
est cependant possible o
de faire apparaitre les
deux courbes sur le
méme graphique. Une
fois le graphique généré
de la méme facon que N
pour une superposition =

Mo

M) = Els = 3,78
LR !

3 =] 13 H p: |

simple, il suffit de sélec-
tionner la courbe a la-
quelle donner une échel-
le différente, de choisir

Figure 6. Régression linéaire avec affichage
de I’équation et du coefficient de corrélation

le menu Format -> Pro- o
priétés de I'objet..., et de
sélectionner I'option Ali-
gner la série de donnée
sur -> Axe Y secondaire
de I'onglet « Options ». 10

Notons que la zone
Paramétres n’est active
que dans le cas d’un his-
togramme (ou «dia-
gramme en barres »).
L'échelle du nouvel axe
est normalement auto-
matique et il suffirait |

wn

Pl

15 I I I

calbgorie 6 cabggorie S caegorie 4 catbgarie 3 categonie I categorie 1

pour la modifier d’aller
dans le menu Format ->
Axe -> Axe Y secondai-
re, onglet « Echelle ».

La souplesse de Calc autorise
également la création de courbes
possédant deux échelles des abs-
cisses différentes, comme dans le
cas des diagrammes binaires. La Fi-
gure 5 représente une seule série
de données en ordonnée mais deux
séries de données correspondant a
deux abscisses différentes possé-
dant la méme échelle.

Pour arriver au résultat voulu, il
suffit de paramétrer I'étape « Sé-
ries de données » de sorte qu'il y
ait deux séries de données identi-
ques pour le champ « Nom » et le
champ «Valeurs Y » mais possé-

Figure 7. Inversion de I'axe des abscisses
dans un histogramme

dant un champ « Valeurs-X » diffé-
rent (ici la colonne x_ pour la pre-
miére et Yy, pour la seconde). Le
tableau suivant résume, a titre
d’exemple, les paramétrages ef-
fectués pour générer les deux cour-
bes de la Figure 5 qui n’en forment
qu’une.

Courbes de régression

A partir d’un tableau & trois colon-
nes (abscisses, ordonnées et mar-
ges d’erreur), nous allons générer
une courbe, en faire une régression
linéaire, afficher la courbe corres-
pondante (voir Figure 6) et enfin pa-

Tableau 1. Les paramétrages effectués pour générer les deux courbes de la Figure 5

Série de donnée

Plage de données

Nom Valeurs-X Valeurs 'Y
$Feuille1.$C$1 $Feuillel.$A$2:$A$13 $Feuille1.$C$2:$C$13
a $Feuille1.$C$1 $Feuille1.$B$2:$B$13 $Feuille1.$C$2:$C$13

www.linuxidentity.com
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sissez Insérer des barres d’er-
reur Y. Dans le premier onglet
(« Barres d’erreur Y »), plusieurs

20 35 o4 25
catégories de marges sont dis-
- . ponibles, parmi lesquelles « Pla-
s L5 ge de ce}lulgs » qui (.:o’rre.spond
10 3 a la catégorie s\ouhaﬂee ici. La
zone «Paramétres» permet
: d’achever l'insertion de ces mar-
: .5 5| ges en sélectionnant les colon-
o 0 nes du tableau correspondan-

L)
[

[=]

-
-

[=]

0,
o i}

cat]l est? catd catd catt et catl ecat? cat3 catd cat5 caté tes.

Pour cela, saisissez directe-

Figure 8. Affichage de deux diagrammes en barres dans un méme repére ment les coordonnées de la (ou

des) colonne(s), ou utilisez le

ramétrer l'affichage des marges rez lire la valeur dans la barre d’état bouton situé a la droite de la

d’erreurs prédéfinies. apreés I'avoir sélectionnée. zone de saisie. Lappui sur ce bou-

La nouvelle version d'Open- ton, qui fait disparaitre la fenétre,

Création de la courbe Office.org permet d'afficher la cour-  permet de sélectionner le groupe de

Considérons donc un tableau de be derégression en lasélectionnant  cellules voulu. Pour retourner dans
données quelconque trié suivant puis en cochant la case «Afficher la fenétre « Indicateur d’erreur », cli-

les valeurs de x. I’équation », de I'onglet « Equation» quez sur le bouton situé dans la
Si ce n'est pas le cas, il suffit, du menu Format -> Propriétés de  barre apparue. Notez que vous avez
aprés avoir sélectionné la totalité I'objet. la possibilité d’employer la méme
du tableau d'utiliser le menu Don- Dans ce méme onglet, vous pou-  colonne pour les erreurs positives
nées -> Trier. En effet, si seule la  vez également demander I'affichage et négatives en cochant la case
colonne des X est sélectionnée, les  du coefficient de corrélation. En re-  « Méme valeur pour les deux ».

valeurs de Y correspondantes ne se-  vanche, il est indiqué dans le graphi-

ront pas déplacées, ce qui aurait que, en dessous de I'équation, sous Diagrammes en barres

complétement modifié le résultat. forme approchée mais vous en avez  Depuis la version 2.4, OpenOffice.
Trier plusieurs colonnes en  une valeur plus exacte dans la barre  org permet de « renverser les axes »

méme temps est possible, méme  d’'état aprés sélection de la courbe  des diagrammes en barres pour ob-

selon des critéres différents. de régression. tenir une mise en forme plus adap-
La procédure pour la création du tée a la représentation voulue. Pour
diagramme est la méme que celle  Marge d’erreurs générer un diagramme en barres,

décrite au paragraphe « Superposi- La version 3.0 d’OpenOffice.org of-  deux colonnes sont nécessaires au
tion de courbes ». Pour faire une ré-  fre la possibilité d’afficher des mar-  minimum, 'une contenant les « ca-
gression, il est obligatoire de choisir ~ ges d’erreurs sur les courbes des  tégories» et I'autre contenant la
comme type de diagramme XY (dis- diagrammes XY. Elles doivent étre  «longueur » des barres. Lutilisation
persion), et ici option «Points définies dans une ligne ou une co- de I'assistant est ensuite similaire a
seuls ». La suite du paramétrage ne  lonne adjacente au tableau de don-  celle décrite ci-dessus. Pour renver-

pose pas de difficultés. nées permettant la génération du  ser les barres suivant I'axe X (voir
graphique. Figure 7), sélectionnez I'axe Y et co-

Modélisation de la courbe Un fois entré dans la fenétre chez la case « Inverser la direction »
et affichage de I'’équation d’édition du graphique, cliquez avec  de I'onglet « Echelle » du menu For-
de régression le bouton droit sur la courbe et choi-  mat -> Propriétés de I'objet.
La régression linéaire de la cour-

, . . A B [ c | ] | E Gl G [ H |
be s’effectue en sélectionnant 1
sur la courbe (ici les points), puis Z Trouver le meilleur profit pour la vente de ces produits
en configurant I'onglet Statisti- | —— — T T P P
ques du menu Format -> Pro- |5 [& 0 100 150 000
priétés de I'objet. Outre la sélec- | & | |écous 0 100 L 7000
tion du type de régression, il est + :::._ ‘ﬁ EE :m'; 1ﬁ
possible de spécifier I'apparition [ 5 | |goujens 10 b [ 800
d’'une marge d’erreur, de la va- :ﬁ: [profit par wnites | )| 120] 150]
riance et de I'écart-type, ou de :ﬁt [quantines produites | [ | |
faire apparaitre la valeur moyen- E [ profit total ]

ne de la courbe sous forme de
ligne horizontale dont vous pour-  Figure 9. Tableau initial
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H Ed cleary (=0 l:l_ 200! A 00y | =L mECE 340 ORI A+ETEERND
La’ nouveIIeAver§|or1 permet df’ B (e % = r Fo) -
présenter cOte a cote deux sé- | | |asujems n » 0 800 0
ries de données et ce, méme [ il [pefparumiis | 0] 1] 150]
lorsque I'échelle de I'axe des or- | 43| [ausstines pooduives | ) 1 )
données associé est différente. | | profit total o]

Supposons que vous dispo-
siez de deux séries de données
pour la méme catégorie. Une
fois le diagramme de type « Colon-
ne », option « Normal » créé, com-
mencez par ajouter un axe des or-
données secondaire grace au menu
Insertion -> Axes -> Axes secon-
daires -> axe y ; puis associez a ce
nouvel axe la seconde série de don-
nées en cliquant sur une barre lui
correspondant et en choisissant le
bouton radio Aligner la série de don-
née sur -> Axe Y secondaire de
I’'onglet Options du menu Format ->
Propriétés de I'objet. Dans ce méme
onglet, il ne reste plus qu’a cocher
la case «Afficher les barres cote
a cote ».

Il est a noter qu’Excel ne possé-
dant pas cette fonctionnalité,
I’export vers le format « .xIs » est im-
possible.

Diagrammes 3D

Les possibilités offertes par la nou-
velle version pour les diagrammes
en trois dimensions concernent sur-
tout le positionnement des étiquet-
tes. Le paramétrage est assez sim-
ple et se fait grace a l'onglet « Eti-
quettes de données » du menu For-
mat -> Propriétés de I'objet. Il est
notamment possible de choisir un
positionnement automatique pour
les étiquettes en sélectionnant un
Placement « Prés de la source ».

Solveur

Le solveur est un outil destiné a ré-
soudre des équations avec plusieurs
variables inconnues par une méthode
de « recherche par objectif ». Il est in-
tégré a OpenOffice.org 3.0 et accessi-
ble via le menu Outils -> Solveur.
Etant donné une plage de cellules
correspondant aux données du pro-
bléme, une cellule «objectif » dans
laquelle sera affiché le résultat, un
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parameétre d’optimisation (maximum,
minimum ou valeur approchée) et une
éventuelle série de contraintes impo-
sées par le probléme (une variable
doit rester inférieure a une autre, doit
rester entiére, etc.), le solveur fournit
la meilleur solution possible. Pour
comprendre, prenons un exemple.

Une entreprise réalise le condi-
tionnement de matériels de fixa-
tion : vis, écrous, clous, chevilles et
goujons, en boites composées d’un
assortiment de ces produits. Elle
propose a la vente trois boites dif-
férentes comportant une quantité
de chaque piéces distincte afin de
répondre a divers besoins. Elle dis-
pose en stock d’une quantité limi-
tée de chacun de ces produits.

Son objectif est de déterminer la
répartition de la production de cha-
cune de ces boites c’est-a-dire le
nombre de boites de chaque type
a produire afin d’optimiser ses bé-
néfices étant donné un profit par

Figure 10. Insertion des formules de calcul

boite défini. Le détail de ces diffé-
rents parameétres est placé dans le
tableau suivant (voir Figure 9).

Avant d’exécuter le solveur, il
reste ainsérer les formules de calcul
du profit total et des quantités utili-
sées dans les cellules correspon-
dantes.

La cellule H5 contient donc la
formule «=C5*C13+D5*D13+E5
*E13». Au lieu de compléter de
méme les cellules suivantes, nous
allons utiliser I'astuce expliquée au
début de I'article, a savoir : insérer
la formule «=C5*$C$13+D5*$D$
13+E5*$E$13 », puis «faire glis-
ser » le contenu de cette cellule vers
les quatre autres cellules inférieu-
res. De cette fagon, les adresses
correspondant aux quantités pro-
duites sont inchangées par le « glis-
sement » (voir Figure 10).

Concernant la formule du profit
total, il suffit, dans notre exemple,
d’insérer dans la cellule C15 la for-

= — )
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Optimize result to @ Maximum o
) Mindmym
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Figure 11. Paramétrage du solveur
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Figure 12. Solution du probléme

mule «=C13*C11+D13*D11+E13
*E11». Comme les précédentes,
cette formule donne bien entendu O
puisque pour l'instant les quantités
produites sont nulles.

Le probleme est maintenant
complétement défini et I'exécution
du solveur peut avoir lieu : Outils -
Solveur. La fenétre qui s’ouvre com-
porte deux zones, la premiére per-
mettant de fixer les paramétres gé-
néraux d’exécution, la seconde
concernant l'introduction de limites.

Tout d’abord, le champ « Cellule
cible » définit la cellule dans laquelle
le résultat doit s’afficher. Il s’agit ici
de la cellule C15. Le bouton « Shrink »
situé a la droite de la cellule permet
d’aller sélectionner directement cet-
te cellule dans la feuille de calcul
bien qu’il soit possible d’en insérer
I'adresse directement.

Le résultat peut étre optimisé de
trois facons différentes : pour étre
maximum, minimum ou pour
s’approcher d’une valeur donnée.
Nous allons ici sélectionner le
bouton radio « Maximum » puis-
gue notre entreprise souhaite fai-
re un profit maximum.

Le champ «Par modifica-
tion de ces cellules» corres-
pond quant a lui aux cellules
qui devront étre modifiées pour
aboutir au meilleur résultat. Ce
sont ici les cellules C13 a E13
(« $CH13:$ES$13 »).

Enfin, certaines conditions
doivent étre respectées lors du
calcul et pour cela, nous allons
fixer des limites : H5 <= G5, H6
<= (6, etc. ce qui correspond
aux limites liées au stock ; C13
>0, D13>0 et E13>0 sont les li-
mites dues au fait que le nombre
de boites produites doit étre po-

sitif. Et enfin, il faut préciser que ce
nombre de boites doit étre entier :
C13 nombre entier, D13 nombre en-
tier et E13 nombre entier.

Toutefois, comme cela peut deve-
nir fastidieux pour un grand nombre
de variables, le bouton «Options »
permet entre autres d’'imposer a tou-
tes les variables d’étre entiéres et/
ou non-négatives, ce qui est le cas
ici. Seules les cing premiéres limites
sont donc a conserver (voir Figu-
re 11). La durée maximale de recher-
che de solutions peut aussi étre mo-
difiée dans la fenétre « Options ».

Il est a noter que ces options va-
rient selon le solveur utilisé. En ef-
fet, le solveur linéaire intégré par
défaut a OpenOffice.org n’est pas le
seul existant : il est possible d’en
ajouter de supplémentaires sous
forme d’extensions.

Pour terminer, un clic sur le bou-
ton « Résoudre » propose une solu-

Calc

tion au probléme et compléte le ta-
bleau (les cellules définies dans le
champ «Par modification de ces
cellules », ainsi que la cellule objec-
tif) avec les valeurs correspondan-
tes (voir Figure 12).

Conclusion

Lintégration du module Chart2 a
Calc avec la version 2.4 a offert
beaucoup de souplesse dans la
conception et la manipulation des
diagrammes sous Calc. Plutét que
d’étre enfermé dans un nombre li-
mité de graphiques types, Calc per-
met la création de toutes sortes de
diagrammes : avec plusieurs abs-
cisses ou plusieurs ordonnées, avec
des échelles différentes, etc.

Cet article ne présente donc
gu’une partie des différentes for-
mes de diagrammes possibles.

Lutilisation du solveur présen-
tée ici ne constistue I'exploitation
que d’'une des nombreuses possibi-
lités de ce nouvel outil. Limplémen-
tation de nouveaux algorithmes de
résolution sous forme d’extension
confére au solveur de Calc un po-
tentiel considérable.

Si I'exemple que nous avons pris
correspond a une utilisation profes-
sionnelle, il est également possible
d’envisager une utilisation personnelle
dans la gestion de son propre budget.
La seule limite du solveur est I'imagi-
nation de celui qui 'emploie ! m

Fichier Edition Affichage Insertion Format Outils Fepétre Aldg

4_- = = & & - > Barre Normal
caEEL 2s s Mo

: : 3 | ¢ | o | ~_ | F | 6 |
7 1 Barre Qutils

3 1 16

4 2 27 ™ - 1
5 3 45 y=fix}

[ 4 T4 0 7
7 5 121 08 =
8 (3 2 ] 7

9 7 30 25 =

) 2 =

11 LH) ] 7

12 a>= i 4
13 128 —

: . Z

15 . s

16 Graphique iy ——

17 o J E—y

18 T 1 2 1 4 3 4 7
19 "

zu - - -
21
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